Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > General

Advice on dash fault lights please
Post Reply  Down to end
Page 1 of 1
alant1206
 


Member Since: 07 Nov 2017
Location: West Midlands
Posts: 5

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Bonatti GreyDiscovery 3
Advice on dash fault lights please

I'm new to LR Disco3s and would appreciate some advice. My Disco3 which I have had for less than a week keeps issuing what appear to be random messages in the dash message center, so far we have had Transmission Fault traction will be reduced, the air bag warning light coming on and today, slow down lowering/raising. All of these messages have come on soon after starting the engine and driving off. I have been told this might be something to do with a low battery voltage due to the cold weather but battery and charging circuit has been checked and seems ok. Any advice please as to what could be going on.
  
Post #187808810th Nov 2017 7:44 pm
View user's profile Send private message View poster's gallery Reply with quote
DSL
Keeper of the wheelie bin 


Member Since: 11 May 2006
Location: Somewhere.
Posts: 56317

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Zermatt SilverDiscovery 4

Original battery, i.e. it's marked up with LR branding? If so Tanya is your friend. Thumbs Up

https://www.tayna.co.uk/EA1000-Exide-Premi...P7488.html
 

11 D4 HSE - just Dee, no more Double Disco. Sad 
 
Post #187809010th Nov 2017 7:50 pm
View user's profile Send private message View poster's gallery Reply with quote
philm
 


Member Since: 02 Oct 2016
Location: Manchester
Posts: 212

United Kingdom 2016 Discovery 4 3.0 SDV6 Landmark LE Auto Waitomo GreyDiscovery 4

Try site search.
just one that came up.

http://www.disco4.com/forum/transmission-f...ht=battery
 Discovery 4 Landmark MY16.
IID Tool BT 
 
Post #187809210th Nov 2017 7:51 pm
View user's profile Send private message View poster's gallery Reply with quote
xcentric
 


Member Since: 01 Apr 2015
Location: Shropshire, UK
Posts: 886

2012 Discovery 4 3.0 SDV6 HSE Auto Baltic BlueDiscovery 4

probably new battery needed. If you need fault codes read I have an IIDTool and can help out - in Shropshire and come to Bham weekly.....
  
Post #187809610th Nov 2017 7:58 pm
View user's profile Send private message View poster's gallery Reply with quote
alant1206
 


Member Since: 07 Nov 2017
Location: West Midlands
Posts: 5

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Bonatti GreyDiscovery 3

Thanks for the replies. Battery is a Yashica brand so guess not original.
  
Post #187810410th Nov 2017 8:06 pm
View user's profile Send private message View poster's gallery Reply with quote
xcentric
 


Member Since: 01 Apr 2015
Location: Shropshire, UK
Posts: 886

2012 Discovery 4 3.0 SDV6 HSE Auto Baltic BlueDiscovery 4

see what the voltage drops to as and after you crank it - if too low then all sorts of faults come up. +1 for Tanya - and their customer service is excellent, took back a battery that didn't fit with no quibbles. Or can you connect a second one via jump leads and start, see if the messages don't appear - as that would point to it being beyond its use-buy date too.....

(welcome here, btw - its a source of good advice, money saving information, and occasional banter)
  
Post #187811210th Nov 2017 8:13 pm
View user's profile Send private message View poster's gallery Reply with quote
alant1206
 


Member Since: 07 Nov 2017
Location: West Midlands
Posts: 5

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Bonatti GreyDiscovery 3

Thanks. My local battery center checked the battery with a FLUKE meter including the voltage after start up and voltage with lights, heated screens and blowers on and said everything seemed to be ok and within tolerance. I'll probably try a new battery anyway. Thanks for your help.
  
Post #187811910th Nov 2017 8:25 pm
View user's profile Send private message View poster's gallery Reply with quote
OJ-LR4
 


Member Since: 01 Oct 2017
Location: Loch Leven
Posts: 359

Scotland 2015 LR4 3.0 SDV6 SE Tech Auto Corris GreyLR4
Re: Advice on dash fault lights please

alant1206 wrote:
I'm new to LR Disco3s and would appreciate some advice. My Disco3 which I have had for less than a week keeps issuing what appear to be random messages in the dash message center, so far we have had Transmission Fault traction will be reduced, the air bag warning light coming on and today, slow down lowering/raising. All of these messages have come on soon after starting the engine and driving off. I have been told this might be something to do with a low battery voltage due to the cold weather but battery and charging circuit has been checked and seems ok. Any advice please as to what could be going on.


Welcome

All sorts of weird things can happen if there is a fault with the brake light switch or dodgy or duff stop/tail bulbs, worth checking these are ok Thumbs Up
 2015 Discovery 4

Gone-2015 Defender Puma 2.2, 2010 Defender Puma 2.4, 2001 Defender Td5, 1993 Defender 200 Tdi


 
 
Post #187812510th Nov 2017 8:35 pm
View user's profile Send private message View poster's gallery Reply with quote
alant1206
 


Member Since: 07 Nov 2017
Location: West Midlands
Posts: 5

United Kingdom 2008 Discovery 3 TDV6 HSE Auto Bonatti GreyDiscovery 3
Thanks

I'll check the brake light switch and lights out thanks
  
Post #187818110th Nov 2017 10:18 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO4.COM on twitter

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site