Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > General

Gearbox F in display P0963
Post Reply  Down to end
Page 1 of 1
norfolkfred
 


Member Since: 07 Oct 2015
Location: gorleston Norfolk United kingdom
Posts: 20

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Unknown ColourDiscovery 3
Gearbox F in display P0963

Here's hoping one of the very knowledgeable members can point me in the right direction, disco 3 auto has gone into limp home mode locked in 3rd gear. I have F in the gear display and on checking fault code P0963 which I believe is pressure control solenoid A control circuit high. Tried all fixes and clear codes disconnect battery but as soon as I start the fault is back. Disco has 125k miles and did a double gearbox flush a few weeks ago. I have now dropped the Medtronic valve body out and have on order remanufactured solenoids but have meterred the old ones and all appear to be right for resistance. Is there anything else I should be checking whilst in the box.i have also ordered the other consumables for putting things back together. Any assistance or experience on this fault would be great. Cheers all. Fred
  
Post #190864531st Jan 2018 11:31 am
View user's profile Send private message View poster's gallery Reply with quote
Skynet
 


Member Since: 23 Jul 2014
Location: Melksham, Wiltshire
Posts: 792

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Cairns BlueDiscovery 3

Have you done a 'search' on the forum as this has surely popped up before with other members...
 Dave
D3 2006 HSE, Cairns Blue

Wessex 4x4 Response
http://www.wessex4x4response.org.uk/ 
 
Post #190865431st Jan 2018 11:50 am
View user's profile Send private message View poster's gallery Reply with quote
norfolkfred
 


Member Since: 07 Oct 2015
Location: gorleston Norfolk United kingdom
Posts: 20

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Unknown ColourDiscovery 3

Lots of faults as we can imagine but not with the p0963 code that I can find, but my search technique not that good.cheers
  
Post #190865831st Jan 2018 11:58 am
View user's profile Send private message View poster's gallery Reply with quote
Skynet
 


Member Since: 23 Jul 2014
Location: Melksham, Wiltshire
Posts: 792

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Cairns BlueDiscovery 3

After all the rain we have had lately, check the ECU behind the battery has clean contacts. This gave me F display issues...
 Dave
D3 2006 HSE, Cairns Blue

Wessex 4x4 Response
http://www.wessex4x4response.org.uk/ 
 
Post #190866031st Jan 2018 12:04 pm
View user's profile Send private message View poster's gallery Reply with quote
norfolkfred
 


Member Since: 07 Oct 2015
Location: gorleston Norfolk United kingdom
Posts: 20

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Unknown ColourDiscovery 3

Thanks have checked and all good after the footwell filling last year from blocked or broken sunroof pipe I am very concious of moisture in electrics.thanks for the idea though
  
Post #190866431st Jan 2018 12:15 pm
View user's profile Send private message View poster's gallery Reply with quote
Canburne
 


Member Since: 15 Jan 2013
Location: Devon
Posts: 1518

United Kingdom 2016 Discovery 4 3.0 SDV6 Landmark LE Auto Waitomo GreyDiscovery 4

Try here

https://www.obd-codes.com/p0963
 .
"the inherent vice of capitalism is the unequal sharing of blessings....the inherent vice of socialism is the equal sharing of miseries" Winston Churchill

2016 D4 Landmark Club Waitomo ...or is it Club Tempest????
2015 D4 HSE Aintree Green 
 
Post #190868131st Jan 2018 12:46 pm
View user's profile Send private message View poster's gallery Reply with quote
norfolkfred
 


Member Since: 07 Oct 2015
Location: gorleston Norfolk United kingdom
Posts: 20

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Unknown ColourDiscovery 3

Many thanks, I have read similar articles and all of a generic nature and it is this reading that made me remove the solenoid as a first step. Checked wiring and connections all ok can't think it is the gearbox pump which is in the torque converter I believe. Very difficult to check wiring continuity and the transmission control unit is attached to the Medtronic valve body now on the bench. Mechanical I can usually manage but electrics leave me cold so other than very simple testing I am at a loss.cheers for the message.
  
Post #190869731st Jan 2018 1:08 pm
View user's profile Send private message View poster's gallery Reply with quote
norfolkfred
 


Member Since: 07 Oct 2015
Location: gorleston Norfolk United kingdom
Posts: 20

United Kingdom 2006 Discovery 3 TDV6 HSE Auto Unknown ColourDiscovery 3

Just a quick update, I fitted new solenoids along with the associated seals on the valve body to gearbox assembly new oil pan and filter plus 7 litres of oil and all is well again. Gear changes feel different and perhaps more precise but only done 20 miles so far. I did not reset adaption as I had read this could cause more issues and I am happy as all working good at this time.i tested the old solenoids with a multi meter and all appeared correct resistance so still a little confused but changing them certainly sorted my p0963 fault.
  
Post #19117107th Feb 2018 9:47 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2018 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site