Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > General

Help! Engine gone bang!
Post Reply  Down to end
Page 1 of 2 12>
Grovea
 


Member Since: 23 Mar 2013
Location: Black Country
Posts: 47

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3
Help! Engine gone bang!

Hi folks, had a quick search on here but would like a few words of wisdom from the guys in the know.
Had car in at garage for some bits of maintenance a couple of weeks ago, including oil and filter change. All has been fine until yesterday, wife driving car and she tells me it 'made a funny noise and steering went heavy' so she pulled straight over and rang me. RAC called, he diagnosed as 'cam belt failure' so it was taken back to my driveway on a flatbed. I haven't yet contacted the garage but, how long after an oil filter being incorrectly fitted could it take before oil starvation manifested itself?? Don't want to phone up garage all guns blazing without a couple of facts. Car is a 2007 TDV6 with 137k, belts were done by main dealer, on schedule at 101k, prior to my ownership. I have had oil and filter changed every 6 months at same garage for the last 3 years. I await you knowledgable responses 👍
  
Post #187259126th Oct 2017 11:35 am
View user's profile Send private message View poster's gallery Reply with quote
Dave T
 


Member Since: 03 Jul 2009
Location: Glasgow
Posts: 5547

England 2016 Discovery 4 3.0 SDV6 Graphite LE Auto Santorini BlackDiscovery 4

If its a 2007, was the oil pump changed when the cam belt was done. Its a known problem with the casing, purely as a guess, I think that is most likely if it wasn't changed.
 2016 D4 Graphite Santorini Black
1994 Defender 90
2012 D4 XS Orkney Grey missing it already
2005 D3 S Maya Gold - Gone but never forgotten

Convoy for Heroes 2011

You Tube vids
http://www.youtube.com/user/msdtdave1

photos
http://s243.photobucket.com/albums/ff15/davetomlin/Off%20Roading/ 
 
Post #187259326th Oct 2017 11:39 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
al cope
 


Member Since: 08 Nov 2005
Location: Oldbury, WM
Posts: 8416

England 2016 Discovery 4 3.0 SDV6 SE Tech Auto Loire BlueDiscovery 4

I'll bet the main dealer didnt change the oil pump (the achiles heal on a 2007), so it could be this thats gone causing the oil starvation and engine failure, rather than an issue from having the oil and filter changed.

Al
 MY16 D4 SE Tech, Loire Blue, Almond Leather, Privacy, plus some other goodies.
Old - MY12 D4 SDV6 XS Auto - Ipanema Sand with Almond Leather - Plus other niceties, and D4.com sticker
Older - D3 TDV6 XS Auto - Lugano Teal with Almond Leather, 20" Stormers, Shiny Tailpipes, DVD/TV - and obligatory D3 sticker
Ancient - D3 TDV6 S - Tonga with Ebony, 20" Stormers, satnav & DVD

If you think you are too small to make a difference - you've never shared a bedroom with a mosquito 
 
Post #187259426th Oct 2017 11:39 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
DSL
Keeper of the wheelie bin 


Member Since: 11 May 2006
Location: Somewhere.
Posts: 56284

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Zermatt SilverDiscovery 4

Was the oil pump changed to a newer type? Could be the casing for that has failed and taken the engine with it. Sad

Typed as a non techie. Thumbs Up
 

11 D4 HSE - just Dee, no more Double Disco. Sad 
 
Post #187259526th Oct 2017 11:39 am
View user's profile Send private message View poster's gallery Reply with quote
Dave T
 


Member Since: 03 Jul 2009
Location: Glasgow
Posts: 5547

England 2016 Discovery 4 3.0 SDV6 Graphite LE Auto Santorini BlackDiscovery 4

Do you two sit there waiting on new topics Whistle Whistle
 2016 D4 Graphite Santorini Black
1994 Defender 90
2012 D4 XS Orkney Grey missing it already
2005 D3 S Maya Gold - Gone but never forgotten

Convoy for Heroes 2011

You Tube vids
http://www.youtube.com/user/msdtdave1

photos
http://s243.photobucket.com/albums/ff15/davetomlin/Off%20Roading/ 
 
Post #187259726th Oct 2017 11:40 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
DSL
Keeper of the wheelie bin 


Member Since: 11 May 2006
Location: Somewhere.
Posts: 56284

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Zermatt SilverDiscovery 4

Your point being? Whistle Whistle
 

11 D4 HSE - just Dee, no more Double Disco. Sad 
 
Post #187259826th Oct 2017 11:41 am
View user's profile Send private message View poster's gallery Reply with quote
Dave T
 


Member Since: 03 Jul 2009
Location: Glasgow
Posts: 5547

England 2016 Discovery 4 3.0 SDV6 Graphite LE Auto Santorini BlackDiscovery 4

no wonder I have 1/11th of your posts Sad Sad
 2016 D4 Graphite Santorini Black
1994 Defender 90
2012 D4 XS Orkney Grey missing it already
2005 D3 S Maya Gold - Gone but never forgotten

Convoy for Heroes 2011

You Tube vids
http://www.youtube.com/user/msdtdave1

photos
http://s243.photobucket.com/albums/ff15/davetomlin/Off%20Roading/ 
 
Post #187260026th Oct 2017 11:43 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Grovea
 


Member Since: 23 Mar 2013
Location: Black Country
Posts: 47

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3

Thanks for quick replies. I'm aware of the oil pump issue but had hoped that as it has done circa 35k since belt change, I'd dodged a bullet. Was just wondering if engine would function with restricted oil flow for two weeks and approx 200 miles before engine went pop! Haven't even lifted bonnet let alone checked filter as I will be possibly getting car taken to garage for inspection. Could be a awkward though as my brother is an employee there and don't want to cause him aggro........
  
Post #187260226th Oct 2017 11:46 am
View user's profile Send private message View poster's gallery Reply with quote
Dave T
 


Member Since: 03 Jul 2009
Location: Glasgow
Posts: 5547

England 2016 Discovery 4 3.0 SDV6 Graphite LE Auto Santorini BlackDiscovery 4

from what you wrote "diagnosed cambelt failure" it does sound most likely that it is the pump casing.....to me that is.
 2016 D4 Graphite Santorini Black
1994 Defender 90
2012 D4 XS Orkney Grey missing it already
2005 D3 S Maya Gold - Gone but never forgotten

Convoy for Heroes 2011

You Tube vids
http://www.youtube.com/user/msdtdave1

photos
http://s243.photobucket.com/albums/ff15/davetomlin/Off%20Roading/ 
 
Post #187260326th Oct 2017 11:49 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
nearlee
 


Member Since: 15 Dec 2012
Location: where the sheep are scared
Posts: 1495

Wales 2005 Discovery 3 TDV6 S Auto Bonatti GreyDiscovery 3

Maybe it should go to another garage for a failure report just so your getting an independent answer.
 Just remember:-
Amateurs built the Ark
Professionals built the titanic 
 
Post #187260526th Oct 2017 11:51 am
View user's profile Send private message View poster's gallery Reply with quote
Erea
 


Member Since: 19 Mar 2012
Location: Munster
Posts: 663

Ireland 2006 Discovery 3 TDV6 Commercial Manual Zambezi SilverDiscovery 3

Isn’t it said here a few times that 2007s oil pumps normally fail about 30k after belt changing. I think you are unfortunately in the “around 30k” bracket.
  
Post #187260626th Oct 2017 11:51 am
View user's profile Send private message View poster's gallery Reply with quote
DSL
Keeper of the wheelie bin 


Member Since: 11 May 2006
Location: Somewhere.
Posts: 56284

United Kingdom 2011 Discovery 4 3.0 SDV6 HSE Auto Zermatt SilverDiscovery 4

Daft question but what sort of funny noise?
 

11 D4 HSE - just Dee, no more Double Disco. Sad 
 
Post #187260726th Oct 2017 11:53 am
View user's profile Send private message View poster's gallery Reply with quote
Grovea
 


Member Since: 23 Mar 2013
Location: Black Country
Posts: 47

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Stornoway GreyDiscovery 3

Erea, that's what I was wondering, I thought I'd read it on here but couldn't find it again last night.
DSL, she just described it as a clatter and everything went sluggish and heavy so she pulled straight over and turned off ignition.
  
Post #187261026th Oct 2017 11:59 am
View user's profile Send private message View poster's gallery Reply with quote
Naks
 


Member Since: 12 Jul 2010
Location: Stellenbosch, Republic of the Western Cape
Posts: 505

South Africa 2011 Discovery 4 3.0 SDV6 SE Auto Fuji WhiteDiscovery 4

you better hope it's not the crank Sad
 Discovery 4 Workshop Manual: http://bit.ly/22l8YHh
Defender Puma Workshop Manual: http://1drv.ms/1nNpJeM
Range Rover/Sport Workshop Manual: http://bit.ly/2iH7jgG 
 
Post #187261226th Oct 2017 12:03 pm
View user's profile Send private message View poster's gallery Reply with quote
Erea
 


Member Since: 19 Mar 2012
Location: Munster
Posts: 663

Ireland 2006 Discovery 3 TDV6 Commercial Manual Zambezi SilverDiscovery 3

I know it’s a very long shot but isn’t Landrover’s standard excuse that the bolt on the oil pump was over tightened. But surely that would mean they would be blaming their own main dealer in this case?
  
Post #187262126th Oct 2017 12:24 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 1 of 2 12>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO4.COM on twitter

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site