Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > General

Multiple issues in the space of several days
Post Reply  Down to end
Page 1 of 1
Andyp24
 


Member Since: 29 Nov 2017
Location: Bedworth
Posts: 8

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Barolo BlackDiscovery 3
Multiple issues in the space of several days

Hi all,

Just had my disco 3 07 serviced and after 2 days of having it back I've had three problems occur. Passenger heated seat has stopped working, airbag light now constantly on red and today my bloody rear drives side indicator has stopped work
ing. On top of this I've had a parking sensor fault which comes up for 10 or 15 seconds when starting up in the mornings and then going out. Any ideas on the above. Thanks all
  
Post #188479029th Nov 2017 1:41 pm
View user's profile Send private message View poster's gallery Reply with quote
Mike40
 


Member Since: 30 Nov 2008
Location: Newport South Wales
Posts: 769

United Kingdom 2006 Discovery 3 TDV6 S Auto Rimini RedDiscovery 3

Airbag light will most likely be a loose connector under the drivers seat.........common problem if they moved the seat right back or forward or vacuumed the car out! Wink

Might be the same for the heated seat? Question

Parking sensor might be water ingress if they jetwashed it. Usually cures itself....
 ------------------------------
"Ruby" Rimini Red
Rimini Red 06MY TDV6 S
Xenons, Bright Pack, Climate Pack,
BAS Magic Box and Remap
ITG Air Filter
ERG's Blanked (Woody32)
Huge Permagrin

Suzuki GSX1400, Triumph Daytona 1200, Yamaha RD500LC, Norton 850 Commando 
 
Post #188480729th Nov 2017 2:17 pm
View user's profile Send private message View poster's gallery Reply with quote
Andyp24
 


Member Since: 29 Nov 2017
Location: Bedworth
Posts: 8

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Barolo BlackDiscovery 3

Thanks Mike for the mega quick reply. I'll take a look at the connectors under both seats. Not sure what I'm looking for mind given the amount of wires under the seats lol
  
Post #188481629th Nov 2017 2:44 pm
View user's profile Send private message View poster's gallery Reply with quote
Pete K
 


Member Since: 15 Jan 2016
Location: GL
Posts: 3305

England 2005 Discovery 3 TDV6 HSE Auto Rimini RedDiscovery 3

I would check that the alternator isn't overcharging asap.
  
Post #188491529th Nov 2017 8:12 pm
View user's profile Send private message View poster's gallery Reply with quote
Andyp24
 


Member Since: 29 Nov 2017
Location: Bedworth
Posts: 8

United Kingdom 2007 Discovery 3 TDV6 HSE Auto Barolo BlackDiscovery 3

Thanks Pete,

Got the car in today so I'll give you guys an update.

Thanks again

Andy
  
Post #188509030th Nov 2017 10:16 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2018 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site