Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > Tips & Tricks

Parrot MKi9200 Bluetooth Incompatibility
Post Reply  Down to end
Page 1 of 1
Disco34
 


Member Since: 23 Jan 2010
Location: Hampshire
Posts: 6

2006 Discovery 3 TDV6 SE Manual Java BlackDiscovery 3
Parrot MKi9200 Bluetooth Incompatibility

All

My first post...so I hope somebody finds it useful, and apologies if I'm repeating a common thread.

My partner bought me a Parrot MKi9200 for Xmas, the bottom line is, its not compatible with the Disco 3 with the HK 7 speaker system. It only plays through two speakers, when you plug an ipod it crashes the system, an RDS broadcast cuts a phone call off.

Beware, its rubbish.

Regards

Andy
  
Post #5969544th Feb 2010 4:14 pm
View user's profile Send private message View poster's gallery Reply with quote
methley
a.k.a. Big Hairy Ski Monster 


Member Since: 07 Oct 2008
Location: Land of the Icecream
Posts: 2373

England 2006 Discovery 3 TDV6 SE Manual Java BlackDiscovery 3

Yawn If you have it installed properly it works fine just like it does in my D3. It sounds very much as if your installer has not connected the line out feed from the parrot to the AUX in of your stereo and you are playing music up the phone connector , hence the front speakers only (and in mono too BTW).

Questions...

1. When you make a phone call does it say "phone mode" on the display?
2. When you play music does it say "phone mode" on the display?

Answer to 1. should be yes. If it's no then you have a bigger problem.
Answer to 2. should be no. If it is yes, try disabling "mute on audio streaming" (or similar) in the Parrot menu. If you do this you should not see "phone mode" on the display when listening to music. If, when playing music, you now cannot hear anything when you select "AUX" on the radio then it's proof the Parrot has not been installed "optimally" to put it kindly.
 Andy  
Post #5969884th Feb 2010 5:01 pm
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
Disco34
 


Member Since: 23 Jan 2010
Location: Hampshire
Posts: 6

2006 Discovery 3 TDV6 SE Manual Java BlackDiscovery 3

Thanks

Showed the installer your comments (th 3rd thats tried to make this work), but he couldn't get past the Parrot rebooting when you plugged in an ipod.

Gave up and had it all removed, going to install a seperate Parrot for the phone and something else for the ipod.
  
Post #60082210th Feb 2010 1:41 pm
View user's profile Send private message View poster's gallery Reply with quote
kernowexpeditionaryforce
 


Member Since: 15 Jan 2009
Location: Kernow
Posts: 329

2006 Discovery 3 TDV6 S Auto Buckingham BlueDiscovery 3

software issue with the ipod (not an iphone is it?)

and the two speaker issue is an install prob, 100%
  
Post #60113810th Feb 2010 9:01 pm
View user's profile Send private message View poster's gallery Reply with quote
Womble
 


Member Since: 07 Jul 2007
Location: Derby
Posts: 32

United Kingdom 2007 Discovery 3 TDV6 XS Auto Zermatt SilverDiscovery 3

Hi
Just had similar problems with the 9100 (but in a freelander (sorry) )

The installer did mentioon that leads are different for those installations that are amplified and knowing the previous D3 XS i had was amplified it might be worth asking if this is the problem.
System should play fhrough all speakers (Ipod connectivity's a must!!) so it's worth persevering

Cheers
  
Post #60770021st Feb 2010 10:54 pm
View user's profile Send private message View poster's gallery Reply with quote
versa6030
 


Member Since: 30 Mar 2010
Location: Southampton
Posts: 3

United Kingdom 2005 Discovery 3 TDV6 SE Auto Zermatt SilverDiscovery 3

hey, my first post on here, but i hope i can be of some help.

I work at a mobile phone retailer with an onsite carkit installation centre, and with the help of a couple of my colleagues we were able to get the parrot to work in my disco with HK7.

It needs to be fitted with the Elan intellimute first off (EMK014 if i remember correctly), and the Elan EAH019 parrot with aux adapter, these adapters make it a lot easier to fit than most carkits, as there is no need to route a wire from the ignition.

Mute on audio streaming needs to be enabled and you need to be on the aux setting on the stereo to get it to play music as methley posted.

One point is that the parrot has had a software update this year allowing a few extra functions, and crucially compatibility with the iphone has been improved so it crashes less and allows it to charge properly.

But i can confirm that mine is working fine, satnav comes out the front while music continues quietly in back, and phone mode comes on when in a call. only annoying thing is that the satnav speaks over the top of calls, so you cant hear the phone.

hope this is helpful, if you have any more specific carkit questions let me know and i will endeavour to help!
  
Post #65024118th May 2010 12:30 am
View user's profile Send private message View poster's gallery Reply with quote
Nasher
 


Member Since: 07 Mar 2009
Location: North of Pompey - UK
Posts: 1665

England 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

Firstly to clarify, this post is in no way a dig at Versa6030, I believe he’s been misled by the people that did the work for him and they’ve created a special cable from the ones supplied.

Get a cup of tea, it’s going to be a long one.

I decided to give versa6030s Elan cables route a go rather than go the tried and trusted Autoleads route, mainly by way of an experiment, for the benefit of others on here, and to see if it worked as well as was suggested.

Versa kindly PM’d me the actual cable part no.s, EPK049 and EAH019, which I checked on the ELan website and found that they are indeed specified for the HK Logic 7 system in D3s and RRSs on Elans site.

I spoke to Elan direct, and they confirmed they were a simple Plug and Play design, by way of a ‘T’ cable that fits in between the head unit and the original connectors. The ‘T’ connects to another cable that replaces the original Parrot loom. They did say at this point that the only additional requirement is to connect a cable to a switched 12V +ve supply.
They would not sell direct to me, but pointed me in the direction of their UK Distributors listed on their website.
I emailed both, and Nemesis replied first. At first they too would not sell direct, but gave me the name of DSL developments, who are a re-seller they recommend. - I certainly would not.
I called them 3 times Wednesday morning and each time they were engaged.
I emailed Wednesday Lunchtime, but carried on calling @ every ½ hour Wednesday afternoon, only to get the engaged tone again. My email had asked for help having the cables delivered by lunchtime on Friday.
At 2 mins past 5 in the evening when I called the office was shut and the answerphone was on.

On Thursday morning I called Nemesis to ask for another re-seller and they very kindly offered to make an exception and sell direct to me direct. We arranged the sale and the cables arrived at my workplace @ 10 am today. I eventually received a reply to my email from DSL at lunchtime on Thursday.

Being lucky enough not to work Friday afternoons, I pulled the cable out of the bag when I got home and immediately realised they would never work.

The ‘T’ cable does have the correct male and female plugs to fit between the head unit and original connectors, but the ‘T’ piece only gives 12V –ve, constant 12V +ve, Mute and one pair of wires for the Phone input, and is terminated by a 20 pin connector.
Included was an adaptor cable that converts the 20 pin connector to std ISO connectors.

The Cable that replaces the parrot cable has both 12V +ves, 12V –ve, mute and phone line out terminating in a 6 way connector, plus a 3.5mm jack socket similar to the Autoleads cable.

But of course, from the above you can see there is no way to connect the cables together, and even if you did using the original Parrot cable and some mucking about only the phone would work.

I phoned Nemesis and spoke to their technical help line who couldn’t have been more helpful.
They instantly knew the cables I was talking about, and the different systems fitted to the D3, and instantly said they would never work, but promised to investigate and phone me back.

True to their word I had a call 1/2hr later explaining that both Elans website and their database were incorrect, which would be put right ASAP and that I would receive a full refund for the cables. They also could not stop apologising.

They did offer to make up a one off special for me which would also serve as a prototype for a new dedicated cable they could sell, but it may take a couple of weeks to sort out.
As they really needed me to be local to do this I declined.

I’ve already ordered the Autoleads cables and, as much fun as it’s been, will stop mucking about trying other routes and listen to the old hands on here who have found the correct way to do it.

Nasher.
 Heaven doesn't want me, and hell is afraid I'll take over.  
Post #65180921st May 2010 7:07 pm
View user's profile Send private message View poster's gallery Reply with quote
RPG
 


Member Since: 23 Feb 2009
Location: The End of the Earth (West Cornwall)
Posts: 712

United Kingdom 

Based on Autoleads cable, most of it is simple and obvious but what isn't is some additional cabling you need to add to the loom. You need to add 3 cables over 4 connectors in order to connect the Line out on the Parrot to the Aux in on the Head unit (else it'll always be in Phone Mode and sound crap and be on 2 speakers):

Take L+ve and R+ve line out from the Parrot 12 pin block and run to red and blue L+R on head unit. Take L-ve and R-ve on Parrot and join together and take to black -ve on head unit. Put a disconnected Aux jack in the rear Aux socket to earth black cable pair in the socket. It won't work without this...you'll get no sound.

Do that and it works great Thumbs Up
  
Post #6794023rd Aug 2010 10:11 pm
View user's profile Send private message View poster's gallery Reply with quote
Woolmeister
 


Member Since: 26 Mar 2007
Location: Chandler's Ford
Posts: 3266

England 

Hi all,

I've just fitted a Parrot Mki9200 kit into my 2007 D3 "S" (with HK amp). I bought it from these guys:

http://www.carcommunications.co.uk/land-ro...-1716.html

And the lead it came with appears to be a:

Autoleads Kram 67687S/X499V1/DA201 Parrot Lead

The phone aspect of the Parrot kits seems to work fine with no trouble at all. D3 stereo goes into "Phone Mode" when I make and receive a call and I can hear it through the front speakers. However, plugging my iPhone into the Apple Dock Connector leaves the D3 stereo display showing "Phone Mode" with the music only coming through the front speakers. Whistle

Sounds as though this is a frequent problem judging by the posts above and I've not wired-in the AUX circuit correctly. Ideally, I want to hear my music in full stereo through all 7(?) speakers in the car.

Do I also need to disconnect the AUX socket from the loom in the rear (or stick a blank in there)?

Please can somebody explain what cable needs to go where when plumbing one of these in? I've not used the cable that came with the Parrot kit yet - only the KRAM cable - so I wonder if this is my first mistake? Big Cry

Do I just attempt to follow what RPG said above?

Thanks! Thumbs Up


Steve
 2017 Discovery Sport HSE Auto in Carpathian Grey and Ebony Leather. Meh.

Gone AND missed:
2007 (2006MY) D3 TDV6 S Manual in Zermatt Silver with Ebony Cloth (143k)
NX07ZKS - Does anybody on here now own this car?

Gone AND forgotten:
1991 D1 5dr 200 Tdi in Firefox Red and a shower above the front seats

Mini Cooper D Convertible
P&H Scorpio 170 
 
Post #10002388th Nov 2012 2:18 pm
View user's profile Send private message View poster's gallery Reply with quote
Riggs
 


Member Since: 16 Apr 2017
Location: Auckland
Posts: 5

New Zealand 2005 Discovery 3 4.0 V6 Petrol SE Auto Zambezi SilverDiscovery 3

This is an old post now but for anyone looking at doing this now and getting confused by a few of these threads. I just had the Mki9200 installed in my 05 SE with 9 speaker amplified stereo by an approved installer through the LR dealership and they installed without any additional leads and everything is working fine so far. I havent plugged in as i only use bluetooth but is all doing what it should with streaming music through all speakers and phone calls through the front speakers. The dealership did say that buying the right loom can help make it easier to install, especially for DIY, but it is not a necessary component to a proper install.
  
Post #180925829th Apr 2017 10:19 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2017 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO4.COM on twitter

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site