Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > General

Roof Rail problems - Fixed at last !!!
Post Reply  Down to end
Page 1 of 2 12>
Hardware17
 


Member Since: 28 Jun 2016
Location: Manchester
Posts: 3323

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4
Roof Rail problems - Fixed at last !!!

I've started a new thread as last one was under "wanted" so didn't want to miss out on any advice because of that.

Short version (story not rails) …

took short rails off to fit long ones … near side rear bolt broke in the hole.

drilled it out (took ages) and started using 6mm tap in the hole. that broke … hindsight I knew it was brittle but trying to get job finished, i'm sure you know what it's like.


many hours of careful drilling and tap is gone … removed is wrong word. it's now dust.

cleared hole and filled it with metal repair epoxy stuff.


drilled ~6mm hole in that and tapped it to 6mm …. top end wasn't too good so partially helicoiled it.


all seemed well as I had a bolt in it and it was deffo fixed and tightened up nicely.


put rail in place, squirt thread-lock stuff into holes and on threads, tighten up and … Censored spins.

can anyone suggest a way forward ? did i just not leave the epoxy long enough ? (it was chuffing cold today but i left it an hour or so)

TIA.
 Dean.
====================================
2011 D4 XS - OBD port protection, RLD spare wheel protector, All LED interiors lights, Timed Climate enabled, iiD tool paired.
2011 D4 Landmark - Stolen from same dealer before I paid for it
2011 D4 GS - Stolen whilst at dealer Sad ... All LED interiors lights, DRLs, Spare Wheel protector.
1996 300Tdi - Eaten by tin worms 


Last edited by Hardware17 on 7th Mar 2018 5:27 pm. Edited 1 time in total 
Post #191500315th Feb 2018 6:18 pm
View user's profile Send private message View poster's gallery Reply with quote
philm
 


Member Since: 02 Oct 2016
Location: Manchester
Posts: 404

England 2016 Discovery 4 3.0 SDV6 Landmark LE Auto Waitomo GreyDiscovery 4

I have some industrial plastic metal if you would like to come and do it.
 Discovery 4 Landmark.
IID Tool BT 
 
Post #191501815th Feb 2018 6:58 pm
View user's profile Send private message View poster's gallery Reply with quote
Grease Monkey
 


Member Since: 24 May 2009
Location: Essex
Posts: 117

England 2010 Discovery 4 3.0 TDV6 SE Auto Zermatt SilverDiscovery 4

Hi Dean

I'm pretty sure you can replace the stud that has the stripped thread, you'll need to dig out the sealant from around the stud, underneath you should find a hex nut. Just undo and refit new stud and reseal. I had this on one of my front fixings. Microcat shows eight fitted to roof, so four per side sounds about right.

Part number is AYR500061



Hope this helps

Matt
 2009 D4 Zermatt Silver SE (Pre-Production) - Current
2014 FL2 Santorini Black HSE - Current
2009 FL2 Zermatt Silver XS - Gone
2005 D3 Zambezi Silver S (ex Bigdave) - Gone
2005 D3 Zambezi Silver SE - Gone 
 
Post #191505015th Feb 2018 7:46 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware17
 


Member Since: 28 Jun 2016
Location: Manchester
Posts: 3323

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

philm wrote:
I have some industrial plastic metal if you would like to come and do it.


That sounds like a plan !

I can come round tomorrow evening if that suit s? PM me your address.

thanks.
  
Post #191506415th Feb 2018 8:22 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware17
 


Member Since: 28 Jun 2016
Location: Manchester
Posts: 3323

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

Grease Monkey wrote:
Hi Dean

I'm pretty sure you can replace the stud that has the stripped thread, you'll need to dig out the sealant from around the stud, underneath you should find a hex nut. Just undo and refit new stud and reseal. I had this on one of my front fixings. Microcat shows eight fitted to roof, so four per side sounds about right.

Part number is AYR500061



Hope this helps

Matt



oh ! on mine it looks suspiciously like something flat welded to the roof but with all the sealant on it you may be right.

Dilemma now !

problem is I've told SWMBO it's sorted, so using the epoxy from Philm might be do-able without letting on that i'm still doing this !
  
Post #191506615th Feb 2018 8:25 pm
View user's profile Send private message View poster's gallery Reply with quote
philm
 


Member Since: 02 Oct 2016
Location: Manchester
Posts: 404

England 2016 Discovery 4 3.0 SDV6 Landmark LE Auto Waitomo GreyDiscovery 4

Would a rivnut do it? also got some of them if you want to try.
 Discovery 4 Landmark.
IID Tool BT 
 
Post #191506815th Feb 2018 8:32 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware17
 


Member Since: 28 Jun 2016
Location: Manchester
Posts: 3323

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

ok .. stud thing ordered from Dan @ Duckworths Thumbs Up

and i'll pop over to Philm's later for the temp fix epoxy.

only concern is that when I had a stud extractor in the broken bolt, it showed no signs of the underlying stud moving … which is why i was convinced it was welded.
  
Post #191526716th Feb 2018 12:32 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware17
 


Member Since: 28 Jun 2016
Location: Manchester
Posts: 3323

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

Phil … a pleasure to meet you sir !

thankfully the mayhem due to rugby traffic had calmed down a bit on the way home … and i got to try the new "divert everyone to the Trafford Centre" bridge Smile
  
Post #191546216th Feb 2018 8:52 pm
View user's profile Send private message View poster's gallery Reply with quote
philm
 


Member Since: 02 Oct 2016
Location: Manchester
Posts: 404

England 2016 Discovery 4 3.0 SDV6 Landmark LE Auto Waitomo GreyDiscovery 4

Nice to meet you, hope you get it sorted.
 Discovery 4 Landmark.
IID Tool BT 
 
Post #191549016th Feb 2018 9:42 pm
View user's profile Send private message View poster's gallery Reply with quote
Aerialmark
Site Supporter 


Member Since: 21 Jun 2015
Location: Burnley (Where the M65 is cobbled)
Posts: 4203

England 2005 Discovery 3 TDV6 HSE Auto Zambezi SilverDiscovery 3

Did you get it sorted Dean ?
 Pendle Transfers
Travel for all occasions to and from any destination in the UK.
www.pendletransfers.com 
 
Post #191566617th Feb 2018 12:57 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware17
 


Member Since: 28 Jun 2016
Location: Manchester
Posts: 3323

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

ish …. Phil's industrial strength epoxy is now holding a bolt in place that will at least minimise any movement until i get back from Devon next week. By then the replacement part from Dan will have arrived and i'll use that to fix it properly. well, that's my theory at least. Smile
  
Post #191598018th Feb 2018 12:53 pm
View user's profile Send private message View poster's gallery Reply with quote
df_tom
 


Member Since: 10 Mar 2017
Location: Stuttgart
Posts: 99

Germany 2007 Discovery 3 TDV6 S Auto Zermatt SilverDiscovery 3

if there's enough metal left, a thread insert might also work.

timesert or helicoil
  
Post #191598318th Feb 2018 1:01 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware17
 


Member Since: 28 Jun 2016
Location: Manchester
Posts: 3323

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

i think the helicoil failed because the new type aren't square section stainless wire as per the originals and it didn't get enough grip into the AYR500061 stud.

i'm confident that if/when i get the old stud out i'll be ok. just finding time whilst SWMBO's not about with reminders that i'm about 20 hours into a 1 hour job so far Laughing
  
Post #191599518th Feb 2018 1:39 pm
View user's profile Send private message View poster's gallery Reply with quote
Grianaig
 


Member Since: 08 Jul 2014
Location: Tyne and Wear
Posts: 921

Scotland 2014 Discovery 4 3.0 SDV6 XS Auto Indus SilverDiscovery 4

Sympathy concerning SWMBO’s ‘interest’ in your attempts. For a long time, on every occasion when I say this will only take ten minutes, there are howls of laughter and the comment, “I’ve heard that before”. Trouble is she is always right. Big Cry
Best of luck with the repair. Thumbs Up
 2014 MY Discovery XS Indus Silver
2006 MY Discovery S Zermatt Silver Manual
2003 MY Discovery S Td5 White Gold
1999 MY Discovery S Td5 Kinversand
1995 MY Discovery S Td 300 Willow Gr
1991 MY Discovery 3 Door Cairngorm
1987 MY 90 County Estate Blue
1980 MY 88 SWB S3 Estate Sand
1970 MY 88 SWB S2a Grey 
 
Post #191600518th Feb 2018 1:53 pm
View user's profile Send private message View poster's gallery Reply with quote
Hardware17
 


Member Since: 28 Jun 2016
Location: Manchester
Posts: 3323

England 2011 Discovery 4 3.0 SDV6 XS Auto Sumatra BlackDiscovery 4

Finally got round to removing the Censored Censored stud thing !

pic on it's way if I can work out how to get it from phone version of gallery to here !
  
Post #19235327th Mar 2018 5:28 pm
View user's profile Send private message View poster's gallery Reply with quote
Display posts from the last:  
Post Reply Back to top
Page 1 of 2 12>
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2018 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site