Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > Webasto Fuel Burning Heater

I think I broke my FBH
Post Reply  Down to end
Page 1 of 1
E4ordy
 


Member Since: 10 Nov 2017
Location: Barnsley
Posts: 5

United Kingdom 
I think I broke my FBH

Hi everyone, just got my Discovery 3 last month and found this site due to sticker in back window, as the weather turned cold I though id check FBH, I could smell the paraffin smell when I got out but wanted to see smoke, I decided to pull the fuse and do the reset and after first start up the smoke was there, however since then I hasn't worked. does anyone in Barnsley area have the cable and computer to check it, or can shed any light, Thanks Elliot
  
Post #18863804th Dec 2017 8:51 am
View user's profile Send private message View poster's gallery Reply with quote
disco4ever
 


Member Since: 23 Dec 2013
Location: under the car
Posts: 278

Germany 2006 Discovery 3 TDV6 HSE Lux Auto Alaska WhiteDiscovery 3

I am not sure a hard reset would help getting rid of any FBH faults.

Check if power comes to the FBH?
 Achim

own garage certified LR tech

Disco 2 TD5 MY 2001 - gone but still driven by another owner
Disco 3 TDV6 HSE MY 2005 fully loaded and kept alive by IID BT
+ EGRs blanked
+ Timing belt done
+ front upper / lower wishbones done
+ front wheel bearings done
+ alternator replaced
+ IC replaced
+ Front diff overhauled 
 
Post #18863974th Dec 2017 9:45 am
View user's profile Send private message View poster's gallery Reply with quote
Gazellio @ Prestige Cars
Site Sponsor 


Member Since: 09 Jan 2011
Location: Chilterns- Site Sponsor
Posts: 3640

United Kingdom 2012 Discovery 4 3.0 SDV6 HSE Auto Scotia GreyDiscovery 4

It's worth noting that pulling that fuse is not a guaranteed reset. Has never worked on my D3's I have to use a code reader.
 
We buy forum member cars - PM to get a quote. http://www.garyelliott.co.uk 
 
Post #18863984th Dec 2017 9:46 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
E4ordy
 


Member Since: 10 Nov 2017
Location: Barnsley
Posts: 5

United Kingdom 

ok, as I say it was working before I did reset, I get no faults but only using a crappy Bluetooth obd2 reader, is there anyone near Sheffield/Barnsley who could help
  
Post #18864004th Dec 2017 9:48 am
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2018 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site