Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > Webasto Fuel Burning Heater

WBus in OBD port?
Post Reply  Down to end
Page 1 of 1
markyzs180
 


Member Since: 21 Sep 2017
Location: West Midlandshire
Posts: 63

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3
WBus in OBD port?

Hi there... I've searched through most of the threads in this section but can't find the answer so...

I've got an early FBH that already has the pin 2 Wbus wire so would I be right in thinking I can just plug my cable directly into the OBD port?

Cheers Thumbs Up
  
Post #188427927th Nov 2017 11:56 pm
View user's profile Send private message View poster's gallery Reply with quote
Narpy
Site Supporter 


Member Since: 18 Jul 2011
Location: Stockport
Posts: 7028

2005 Discovery 3 TDV6 S Manual Cairns BlueDiscovery 3

What cable are you intending to plug into the OBD port?
 Mods:
Front Fogs + Halos
FBH Remote Control
The 1st Ever RRS Modded Grill
Garmin Nuvi + D4 Surround + Reversing Camera.
D4 Steering Wheel.
Rear Boot Spoiler.
Twin Brake Lights.
Wing Mirror Indicator Repeaters.
Long Roof Rails
Make your own Narpy grill thread
Your light eclipsed the moon tonight. 
 
Post #188428528th Nov 2017 12:15 am
View user's profile Send private message View poster's gallery Reply with quote
Martin
Site Admin and Owner 


Member Since: 06 Nov 2004
Location: Hook Norton
Posts: 17218

Wales 2006 Discovery 3 TDV6 SE Manual Buckingham BlueDiscovery 3

No, you can wire the WBUS line to the OBD port so you can use a KKL adapter directly, but that wiring is not there from the factory.

www.disco3.co.uk/fbh
 06 D3 SE / 15 LR D90 XS SW / 88 LR 90 Td5 / 68 BMW 2000 ti
Any issues with the site let me know! 
 
Post #188429628th Nov 2017 12:46 am
View user's profile Send private message View poster's gallery Send e-mail Reply with quote
markyzs180
 


Member Since: 21 Sep 2017
Location: West Midlandshire
Posts: 63

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3

Thanks for the replies gents Thumbs Up

I'll be using a blue 409.1 vagcom cable (if I can remember where it is!)

Just thought that as mine was an early one it may already be wired to the OBD but not a problem I'll just snip the red pin 2 wire and go in that way - fingers crossed!

Ordered the pin 2 wire from the shop for a mates RRS as well Thumbs Up
  
Post #188454928th Nov 2017 7:54 pm
View user's profile Send private message View poster's gallery Reply with quote
markyzs180
 


Member Since: 21 Sep 2017
Location: West Midlandshire
Posts: 63

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3

Ok guru's quick (and maybe dumbass) question...

I've already got the pin 2 Wbus in the 8 pin connector so I have snipped this and connected to pin 7 on the OBD lead, connected to 12v and neg, fired up the WTT software, changed the com port, hit the diagnose button and.... nothing! Software sits there saying 'initialising' so, dumb question time...

do i need the iginition on? Embarassed

I know that the CAN may affect the webasto software but I was hoping to quickly clear the lockout faults then disconnect it all and then just let the car fire it up as its well below 5 degree's...
  
Post #189039914th Dec 2017 10:21 pm
View user's profile Send private message View poster's gallery Reply with quote
zinke
 


Member Since: 22 Feb 2014
Location: Scunthorpe
Posts: 535

2006 Discovery 3 TDV6 S Manual Zermatt SilverDiscovery 3

When I connect my laptop up, using the cable I got from Martin, I have to connect it all up and then pull the fuse for the heater and count to 10 before putting in back, it then connects straight away. If I just plug it in without pulling the fuse I get the same problem your having.

Pete.
 IID, webasto software and workshop facility's available.  
Post #189110117th Dec 2017 12:11 am
View user's profile Send private message View poster's gallery Reply with quote
markyzs180
 


Member Since: 21 Sep 2017
Location: West Midlandshire
Posts: 63

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3

Thanks Pete... I'll give that a try Thumbs Up
  
Post #189120517th Dec 2017 12:20 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2018 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site