Advertise on DISCO4.COM
Forum · Gallery · Wiki · Shop · Sponsors
DISCO4.COM > Webasto Fuel Burning Heater

Well another fbh not working
Post Reply  Down to end
Page 1 of 1
Rob9990
 


Member Since: 06 May 2017
Location: Southeast
Posts: 43

United Kingdom 2009 Discovery 3 TDV6 HSE Auto Santorini BlackDiscovery 3
Well another fbh not working

Hi all.
This is my first winter with the D3.
After reading all about the working parameters for the fbh I have yet to see it fire up. The best it managed was a small puff of smoke one morning last week.
So a bit more reading and a pointer from Martin I pulled Fuse 28 to see if this would cure it. Well it didn't unfortunately.
I'm like a dog with a bone when it comes to things not working so my options are. Take it in and get it sorted out or have a go myself and that's what I'm going to do.
Ordered the diagnostic lead as well as the other one from e-bay (KKL lead I think). While I wait for them to arrive I'm going to try and download the software and get that side of things ready.
Not sure what I'm supposed to do with it once downloaded but hope it's self explanatory.
Will let you know how it all goes. Thumbs Up
  
Post #188136319th Nov 2017 8:09 pm
View user's profile Send private message View poster's gallery Reply with quote
MrH
 


Member Since: 08 Aug 2007
Location: Not a clue, do you know?
Posts: 7319

Wales 2010 Discovery 4 3.0 TDV6 HSE Auto Bali BlueDiscovery 4

Have a search on here, there’s a complete strip down and rebuild guide somewhere, might be a good place to start with an older one.
 IID (BT)
2010MY - my 100+k miles workhorse
2016MY - SWMBOs posh chariot

https://www.justgiving.com/fundraising/matthias-henrich 
 
Post #188136819th Nov 2017 8:15 pm
View user's profile Send private message View poster's gallery Reply with quote
Narpy
Site Supporter 


Member Since: 18 Jul 2011
Location: Stockport
Posts: 6327

2005 Discovery 3 TDV6 S Manual Cairns BlueDiscovery 3

The FBH software is notoriously temperamental and won't always connect to the FBH.
Many people have reported you'll need a particular laptop and a particular lead etc. etc.

In my opinion, spend the money making yourself an FBH controller using the 1533 timer. You'll use this over and over again whereas with the software, you'll use it very infrequently and may only use it once if you get it to connect at all. Rolling Eyes
To be brutally honest, there is an obsession bordering on paranoia when it comes to these things, they are often working but people convince themselves theirs isn't because there's no smoke.
They don't all smoke. Mine has run perfectly for the 6 years or more I've owned the D3 and hasn't smoked one iota in that time.

Build a controller, you'll not regret it and if you do need it plugging up with the software, find some one who has a working version and go round to visit. Thumbs Up
 Mods:
Front Fogs + Halos
FBH Remote Control
The 1st Ever RRS Modded Grill
Garmin Nuvi + D4 Surround + Reversing Camera.
D4 Steering Wheel.
Rear Boot Spoiler.
Twin Brake Lights.
Wing Mirror Indicator Repeaters.
Long Roof Rails
Make your own Narpy grill thread 
 
Post #188137119th Nov 2017 8:17 pm
View user's profile Send private message View poster's gallery Reply with quote
Rob9990
 


Member Since: 06 May 2017
Location: Southeast
Posts: 43

United Kingdom 2009 Discovery 3 TDV6 HSE Auto Santorini BlackDiscovery 3

Cheers Mr H and Narpy.
Definitely not working, exhaust cold and not running with head under bonnet.
Good idea with the timer but have already ordered leads now so going to stay with it and see what happens.
  
Post #188137919th Nov 2017 8:42 pm
View user's profile Send private message View poster's gallery Reply with quote
Narpy
Site Supporter 


Member Since: 18 Jul 2011
Location: Stockport
Posts: 6327

2005 Discovery 3 TDV6 S Manual Cairns BlueDiscovery 3

Good luck. Thumbs Up
 Mods:
Front Fogs + Halos
FBH Remote Control
The 1st Ever RRS Modded Grill
Garmin Nuvi + D4 Surround + Reversing Camera.
D4 Steering Wheel.
Rear Boot Spoiler.
Twin Brake Lights.
Wing Mirror Indicator Repeaters.
Long Roof Rails
Make your own Narpy grill thread 
 
Post #188138219th Nov 2017 8:45 pm
View user's profile Send private message View poster's gallery Reply with quote
Rob9990
 


Member Since: 06 May 2017
Location: Southeast
Posts: 43

United Kingdom 2009 Discovery 3 TDV6 HSE Auto Santorini BlackDiscovery 3

Cheers Mr H and Narpy.
Definitely not working, exhaust cold and not running with head under bonnet.
Good idea with the timer but have already ordered leads now so going to stay with it and see what happens.
  
Post #188138319th Nov 2017 8:46 pm
View user's profile Send private message View poster's gallery Reply with quote
DaveDisco3
 


Member Since: 29 Apr 2014
Location: Gretton, Northamptonshire.
Posts: 596

United Kingdom 2005 Discovery 3 TDV6 HSE Auto Tonga GreenDiscovery 3

I fitted a brand new D4 FBH to my D3 today as it was getting a bit tired. Picked up the D4 one at the Peterborough lro show, now working perfectly 👌
 D3 Tonga HSE 2005
Sport body kit
Beanie grille
LED interior lights
LED side lights
De-tango
IID Bluetooth
Icarsoft i930
Clock on dash
Three flash indicators 
 
Post #188140819th Nov 2017 10:07 pm
View user's profile Send private message View poster's gallery Reply with quote
Rob9990
 


Member Since: 06 May 2017
Location: Southeast
Posts: 43

United Kingdom 2009 Discovery 3 TDV6 HSE Auto Santorini BlackDiscovery 3

Leads arrived today.

After getting back from the dentist, 2 fillings and a tooth pulled.(my face is so numb). I decided to get the laptop set up. Thinking I may as well have a headache at the same time.

Just for info. Laptop is running windows 10.

Already downloaded the thermo test software, v3.4
Plugged in the KKL lead and computer recognised it downloading drivers, without my help. So far so good. Thumbs Up

Next, as per instructions, find com port. Mmmmm.
After some help from Martin. got the device manager up and found where I needed to be. A few taps and clicks later. Com port found, which in my case left as no.3

Opened up the thermo test software and from the dropdown list picked heater (thermo top v/v evo).
Again from instructions. Click on extra's then com port. Select 3 to match up. Job done Mr. Green

So laptop all set up, hopefully. Still got a numb face though.

Mrs has the car today so will be trying later this week. Fingers crossed.
  
Post #188204521st Nov 2017 2:00 pm
View user's profile Send private message View poster's gallery Reply with quote
Rob9990
 


Member Since: 06 May 2017
Location: Southeast
Posts: 43

United Kingdom 2009 Discovery 3 TDV6 HSE Auto Santorini BlackDiscovery 3

Had some time to play about this afternoon.

Wired the plugs up as directed. Opened software and that's as far as I could get. Every time I tried to run the diagnostics an error message popped up " com port not available ". Decided to put car back as it was and go back indoors. Big Cry

Time to play about with the computer. A few e-mails later (Martin). The software would not recognise the com port so messed around for a while and managed to sort it out. This was probably the worst part for me.
Back outside and plugged in. To my astonishment it worked.
Ran the diagnostics and cleared faults. Fired up the fbh and on the second attempt away it went. Let it run for a while and shut down.Then did the same again without any problems Mr. Green

Just need to wait for the temp to drop now.

  
Post #188255122nd Nov 2017 6:47 pm
View user's profile Send private message View poster's gallery Reply with quote
Rmacaul
 


Member Since: 05 Apr 2017
Location: Angus
Posts: 54

Scotland 2009 Discovery 4 3.0 TDV6 XS Auto Indus SilverDiscovery 4

My D4 FBH threw a wobbler the other day, I never managed to catch a look at the error message that it quickly threw up. So spent the Censored trip was thinking another thing to spend money on, Got home switched it off and grumped inside read this forum the way forward.

Out the next day and managed to catch the message......

It was not able to run as the fuel level is low or the battery low.

Fuel was low under 80 miles to empty when I left the house first time.

So went and filled up and yup it is working again. Whistle Whistle Embarassed Embarassed
  
Post #188255522nd Nov 2017 7:09 pm
View user's profile Send private message View poster's gallery Post Reply
Display posts from the last:  
Post Reply Back to top
Page 1 of 1
Jump to:  
Previous Topic | Next Topic >


Posting Rules
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



DISCO4.COM Copyright © 2004-2018 Futuranet Ltd & Martin Lewis
DISCO3.CO.UK RSS Feed - All Forums Follow DISCO4.COM on twitter

DISCO4.COM is independent and not affiliated to Land Rover.
Switch to Mobile Site